Page 1 of 4 1 2 3 ... LastLast
Results 1 to 15 of 54

Thread: Server updated to W3 1.28.5

  1. #1
    Administrator Cen's Avatar
    Join Date
    Sep 2006
    Location
    Slovenia
    Age
    28
    Posts
    15,475
    Blog Entries
    2

    Server updated to W3 1.28.5

    Update instructions on WiKi.

    In short:
    -if you are existing user on 1.28.2, client should autoupdate you and you don't have to do anything. Just run the client, leave it be until it finishes (1-2 minutes).
    -if autoupdate fails for whatever reason:
    --use launcher or full w3 update to update your game, then run installer v9 (see wiki)
    --open a topic in technical support with content of xpam.log


    Me and other moderators will be available on the forum and discord extensively in the next days for troubleshooting.


    Portuguese translation and video tutorial is in the works.

    La, Br and Ss bots should be back online.

    Ent bots should be back soon too, I notified the head admin.


    What is new?
    -1.28.5 fixes stupid bugs from 1.28.2 like non-unicode windows names etc
    -client should now be able to (quickly) update the game automaticaly, if you are using english unmodified w3
    -you can download the full (correct) game version from a client using the "Perform full W3 update" button if quick update fails for some reason
    -better 4K screen support in installer and client
    -fixed many client bugs, such as changing w3 path to blank
    -client will auto-download missing dota map for you on startup
    -some prep work for dota 6.88 which is currently hidden. Dota 6.88 is not yet default and not ready.


    List of problems and solutions: http://eurobattle.net/threads/207120...-and-solutions


    Best regards, Administration


    PS: stefos says hello
    Last edited by Cen; 19th August 2017 at 02:06 PM.

    Undefeated Mad Balls Arena champion

  2. #2
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    Hi there, i'm running on linux and it worked well since this update. Now i have Patch error when try to turn on. "There was an error patching war3.exe (Unable to read memory). Make syure you are using version 1.22a-1.28a."
    Once i had similar error on previous version and i fixed it by replace some files. I checked war3.exe and it does works (game turn on but can't connect to server). I have the same error when try open w3l.exe. Could you help me? or i have to connect by other server?
    PS I don't paste here log file because there isn't nothing useful. Opening in terminal didn't show nothing useful too.

  3. #3
    Administrator Cen's Avatar
    Join Date
    Sep 2006
    Location
    Slovenia
    Age
    28
    Posts
    15,475
    Blog Entries
    2
    Quote Originally Posted by kacior View Post
    Hi there, i'm running on linux and it worked well since this update. Now i have Patch error when try to turn on. "There was an error patching war3.exe (Unable to read memory). Make syure you are using version 1.22a-1.28a."
    Once i had similar error on previous version and i fixed it by replace some files. I checked war3.exe and it does works (game turn on but can't connect to server). I have the same error when try open w3l.exe. Could you help me? or i have to connect by other server?
    PS I don't paste here log file because there isn't nothing useful. Opening in terminal didn't show nothing useful too.
    Did you get the new w3l.exe that comes with the installer?

    Btw, as far as I know, w3l stopped working on linux since 1.27b due to ASLR differences in wine and windows. Not sure how you got it working on 1.28.X.

    Undefeated Mad Balls Arena champion

  4. #4
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    I don't updated it manually. I used automatic mode from xpam.exe.
    I don't remember how i forced it to works. It was long time ago. But as i remember firstly i made it works on europe.warcraft3.eu server. Then I made something and it worked on eurobattle.net too. I'll send here solution if i will find any.
    EDIT
    Can i download only the newest patch?
    Last edited by kacior; 18th August 2017 at 11:29 AM.

  5. #5
    Registered User J0c3r's Avatar
    Join Date
    Jan 2010
    Location
    Transylvania
    Posts
    11
    Unable to validate game version. Please connect to Battle.net, or apply....... (1.28.5.7680) had no problem with the old patch.

  6. #6
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    I came back to 1.28.2 to update it again, but xpam see like it is 1.28.5 and doesn't want to let update it. It is actually this elder version because i checked it in game.
    I can connect by battle.net because i haven't key.

  7. #7
    New User
    Join Date
    Aug 2017
    Location
    Serbia
    Age
    21
    Posts
    2
    Hello, until this patch eurobattle was working fine but starting from this one whenever i try to run gproxy gateway or normal gateway or just warcraft i get this error: Warcraft III was unable to initialize. Error 3. If someone could help me how to solve this since this was not problem on any other patch until this one, atleast for me.

  8. #8
    Administrator Cen's Avatar
    Join Date
    Sep 2006
    Location
    Slovenia
    Age
    28
    Posts
    15,475
    Blog Entries
    2
    Quote Originally Posted by MasterOgi View Post
    Hello, until this patch eurobattle was working fine but starting from this one whenever i try to run gproxy gateway or normal gateway or just warcraft i get this error: Warcraft III was unable to initialize. Error 3. If someone could help me how to solve this since this was not problem on any other patch until this one, atleast for me.
    Try to do a full update.

    Undefeated Mad Balls Arena champion

  9. #9
    New User
    Join Date
    Aug 2017
    Location
    Serbia
    Age
    21
    Posts
    2
    yeah that's what i have done since autoupdate didn't work

  10. #10
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    I tried full update. I downloaded all patches, this 1gb and then i got error while patching. I couldn't do anything, then restarted xpam and then it wanted to download it again ;/.
    EDIT: Could someone look in this file to look for the patch file? C:\users\kacior\Local Settings\Application Data\Blizzard\Warcraft III\BattleNet\Downloads\www_warcraft3_eu_enUS.mpq
    Of course instead of kacior your own name and not necessarily this file. Just patch, maybe updater didn't remove this.
    Last edited by kacior; 18th August 2017 at 02:03 PM.

  11. #11
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    @MasterOgi Have you tried to connect by warcraft3.eu?

  12. #12
    Administrator Cen's Avatar
    Join Date
    Sep 2006
    Location
    Slovenia
    Age
    28
    Posts
    15,475
    Blog Entries
    2
    Hmm google search for this error does not bring anything obvious. I'd try a game reinstall with the launcher tool.

    Undefeated Mad Balls Arena champion

  13. #13
    Registered User
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    16
    I have updated w3 to 1.28.5.7680 warcraft works well but now i can't connect to eurobattle neither warcraft3.eu. I got error "Unable to validate game version. Please reconnect to Battle.net, or apply the current game patch manually."
    Now i don't know how to solve it, none useful notifications or errors.

  14. #14
    Hello all,
    I have too problem with connection to W3.
    Update runed automatically and everything was ok.
    But if i join gproxy it can´t join to W3.
    In log i see this error: [18-08-2017 16:10:04][SYSTEM][LOG_INFO] Waiting W3... [18-08-2017 16:10:05][SYSTEM][LOG_ERROR] W3 did not start in time. Shutting down
    18-08-2017 16:10:05][SYSTEM][LOG_INFO] GPROXY EXITING

    Could someone help me with this issue ?

  15. #15
    Registered User
    Join Date
    Sep 2009
    Location
    Czech Republic
    Age
    27
    Posts
    29

    Activation of ACC

    Hello, ACTIVATION for ACC is doesn't work.

Page 1 of 4 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Inne strony: Film Filmy 2017 Horror 2017


Affiliates